Automagic Running, but doesn't consistently execute flows ... until opening app

Post your questions and help other users.

Moderator: Martin

Post Reply
Posts: 11
Joined: 25 Jul 2017 18:24
Location: Hampton Roads, Virginia, USA

Automagic Running, but doesn't consistently execute flows ... until opening app

Post by e-ec-ecu » 19 Apr 2019 18:12

Samsung Galaxy S8+ on Verizon. Automagic version 1.37.0. Phone recently update to Android P

Automagic has worked flawlessly in the past. I looked for similar issues in the fourm but couldn't find anything. Here are the details.

- Flow to check location every 5 minutes
- When entering "work location", change ringer mode to vibrate
- Another flow to check location every 5 minutes
- When leaving "work location", changes ringer mode to normal

- Also, have another flow that turns ringer off at 11pm and another flow to turn ringer back to normal at 7am.

This has previously worked fine with no issues. Currently, it works most of the times (>75%), but occassionally it doesn't execute. Here is what I notice.

- After entering work location, I notice after 10 minutes that my ringer is still on.
- I assume that my location isn't quite right, so I swipe down on the screen and see "Automagic Service is Running" and click Automagic Premium.
- IMMEDIATELY all of the Automagic flows run (they all go red) and everything sets correctly.

Another example is at 11:30pm. The flow to turn off the ringer at 11pm should have run ... but it didn't. Swipe down on the screen, open Automagic and VOILA, all the flows run and set everything accordingly.

Any help?


User avatar
Posts: 2709
Joined: 21 Jul 2017 17:50

Re: Automagic Running, but doesn't consistently execute flows ... until opening app

Post by Desmanto » 20 Apr 2019 14:07

It happens again, and always on Samsung device with Pie ROM. You will need to check again the app monitor (samsung built-in battery saver) and whitelist/exclude Automagic from the optimization. And remember to modify all time based related trigger to have the doze option checked. This is very similar problem with S10+ here : viewtopic.php?f=5&t=7999

@Martin : I think you should start a sticky thread to announce about this. Recently, many phone vendors started to become so aggresive toward killing apps. Nokia, Oneplus, Xiaomi, Oppo, Vivo, and now even Samsung also did it. This is why they put up a website just to discuss about this issue :

I can help to post some information related to Xiaomi and custom ROM with LineageOS based and RR ROM (as I am using it now). In LOS based ROM, beside the standard android battery optimization, it is the privacy guard that mess up the app sometimes. Whitelisted Automagic, and it works completely fine without any visible battery drain.
Index of Automagic useful thread List of my other useful posts (and others')
Xiaomi Redmi Note 5 (whyred), AOSP Extended v6.7 build 20200310 Official, Android Pie 9.0, Rooted.

Post Reply