location trigger not working

General discussions about Automagic and automation in general

Moderator: Martin

Post Reply
vamzicool
Posts: 67
Joined: 29 Dec 2014 17:47

location trigger not working

Post by vamzicool » 11 Jan 2015 04:55

http://automagic4android.com/flow.php?i ... 1fb0275f0d

The above flow uses the location trigger to turn on/off WiFi on enter/exit of my work location. But it never works. I don't want to use periodic location trigger . what am i doing wrong here?

User avatar
Martin
Posts: 4437
Joined: 09 Nov 2012 14:23

Re: location trigger not working

Post by Martin » 12 Jan 2015 19:39

Hi,

The location radius of 10 meters is extremely small which means that the flow might never be executed when the device determines the location slightly wrong. I would increase the location radius to about 100 meters and check if the flow is executed.
Using a condition Location is also a risk in this case since you have configured slightly different locations in the trigger and condition which means that it's even less likely that the flow ever executes the true-branch of the condition. I therefore recommend to replace the condition Location in the flow by a condition Location Entering since the location was already determined by the trigger and you only need to check if you entered or exited the location.

In the past it also happened that the location services of some devices stopped to work for no apparent reason. I would try to reboot the device once when the flows still don't work with the bigger radius.

Regards,
Martin

vamzicool
Posts: 67
Joined: 29 Dec 2014 17:47

Re: location trigger not working

Post by vamzicool » 15 Jan 2015 15:13

Thanks Martin. the flow worked with a radius of 100 metres and the location entering condition. For the location trigger , the modern method is working fine.

Post Reply