Automagic seems fine under Android 11

General discussions about Automagic and automation in general

Moderator: Martin

Post Reply
guuzendesu
Posts: 51
Joined: 15 Jan 2014 08:25

Automagic seems fine under Android 11

Post by guuzendesu » 04 Apr 2021 11:07

I read some horror stories in the "Will Android 11 break Automagic?" post. As far as I can tell with my somewhat limited testing, those horror stories were one-offs, or perhaps brand/carrier specific.

I got a new S7 tablet with Android 11, and most Automagic functionality is still fine, aside from what is no doubt crippled in other standard automation apps as well, such as screen recording and such.

The widgets seem fine, clipboard works, there are even a few features that Play Store apps had to abandon to stay in the store (Add and Remove WiFi Access Point, at least).

So don't let the new Android scare you away just yet. I plan to use it until it won't start at all, I'll just have Automagic trigger crippled functions in MacroDroid when the time comes. Of course if the Automate devs wake up and fix their clunky interface, I'll gladly switch to that, as it's quite powerful. But so far it's a nightmare to use, in comparison.

monkeynuts1469
Posts: 2
Joined: 22 Oct 2018 19:20

Re: Automagic seems fine under Android 11

Post by monkeynuts1469 » 25 Jun 2021 11:13

Can't seem to get it installed fully on Android 11 , on install it wants to grant access to the internal storage.
When I choose a folder in Downloads and say "Use this folder" on my internal SD or Internal folders , then say allow to the prompt I get an error
"Could not get access to the Internal storage. Please verify that you selected the internal storage when granting access"

Anyone else had this ?

Wibbly
Posts: 405
Joined: 17 Mar 2014 09:02

Re: Automagic seems fine under Android 11

Post by Wibbly » 25 Jun 2021 11:33

Works fine here (Pixel 3a). It's Android 12 that worries me...

monkeynuts1469
Posts: 2
Joined: 22 Oct 2018 19:20

Re: Automagic seems fine under Android 11

Post by monkeynuts1469 » 25 Jun 2021 11:35

Just to note I am using an Xiomi Redmi 10 Pro which has just been acquired and am using Version 1.38.0 Automagic Premium Build 20200802_201222_af0575e

Wibbly
Posts: 405
Joined: 17 Mar 2014 09:02

Re: Automagic seems fine under Android 11

Post by Wibbly » 26 Oct 2021 20:46

Just tried to install on a new phone (Android 12/Pixel 6) and now have the same issue. Did you solve it?

It was fine when my old 3a XL phone updated to Android 12, but the need to reinstall on the new phone seems to have killed it. Something to do with scoped storage, I fear.

Post Reply