Gboard is slowing down

Post your questions and help other users.

Moderator: Martin

elektroinside
Posts: 69
Joined: 14 Feb 2019 15:04

Re: Gboard is slowing down

Post by elektroinside » 27 Feb 2019 16:13

Same thing happens to me as well. At first I thought it was just because of the script editing, but then I realized that in time, as flows are executing, the slowdown reappears even without opening the Automagic UI. Slower than editing the scripts, but it's there after a while. Swiftkey behaves somehow similarly in my case. The stock MIUI keyboard does not, however.
The only thing that really helps is a device restart. Killing the Gboard is a half temporary fix, as it is still slowed down afterwards, just not that much.

elektroinside
Posts: 69
Joined: 14 Feb 2019 15:04

Re: Gboard is slowing down

Post by elektroinside » 28 Feb 2019 10:08

I'll check with "hacker's keyboard" and report back. For developing flows, i think it's a better fit anyway :-)

yxd0018
Posts: 85
Joined: 05 Dec 2018 15:14

Re: Gboard is slowing down

Post by yxd0018 » 04 Mar 2019 04:12

same here, cursor becomes random, backspace is the worst.
android 9

yxd0018
Posts: 85
Joined: 05 Dec 2018 15:14

Re: Gboard is slowing down

Post by yxd0018 » 04 Mar 2019 04:26

elektroinside wrote:I'll check with "hacker's keyboard" and report back. For developing flows, i think it's a better fit anyway :-)
How do you switch to diff keyboard while in automagic? sample flow?

ariloc
Posts: 109
Joined: 05 Jun 2016 21:36

Re: Gboard is slowing down

Post by ariloc » 04 Mar 2019 04:59

yxd0018 wrote: How do you switch to diff keyboard while in automagic? sample flow?
It's pretty simple. I have two flows, both use the action Set Default Input Method. The triggers are App Task Started and App Task Ended. If Automagic is started, the default input method turns to Hacker's Keyboard in my case. When exiting the app, it turns back to Gboard. This also kind of resets Gboard so no delay is present when using it, even with Automagic running. It can be improved, as I experience some weird issues when writing in the forum, so maybe you can change the trigger to something activity based, so you can also use Gboard in the forum within Automagic, or just use your mobile browser :)

EDIT: Just checked and the action requires root. I made a quick Google search and found out you can use Set System Setting to change it if your device is not rooted. There's a Secure system setting called default_input_method which seems to point to an activity of the package of the keyboard app. Try to change the input method manually and register the values you want so you can then change them. Also remember that changing Secure system settings require you to give permission to AM via adb.

yxd0018
Posts: 85
Joined: 05 Dec 2018 15:14

Re: Gboard is slowing down

Post by yxd0018 » 04 Mar 2019 11:56

Thanks. Use hackers keyboard for both automagic and Citrix remote access now.

elektroinside
Posts: 69
Joined: 14 Feb 2019 15:04

Re: Gboard is slowing down

Post by elektroinside » 04 Mar 2019 12:31

No issues here since switching to "hacker's keyboard". All is good. Although, it would be nice to find out why Gboard is acting like this.

natong
Posts: 77
Joined: 29 Aug 2015 05:24

Re: Gboard is slowing down

Post by natong » 07 Jun 2019 10:50

I faced the same problem. Need to stop Gboard when lag or use another keyboard. But I love Gboard.


Android 6 and 9.
Redmi Note 7 and Lenovo K3 Note.
Automagic 1.37
Gboard 8.2.11.xxxx

User avatar
Automagician.gaurav
Posts: 15
Joined: 25 Aug 2017 18:13

Re: Gboard is slowing down

Post by Automagician.gaurav » 29 May 2020 08:08

This is still an issue with latest gboard and automagic versions as of today
Thanks for reading this post.

- Gaurav
Automagician, India

natong
Posts: 77
Joined: 29 Aug 2015 05:24

Re: Gboard is slowing down

Post by natong » 30 Aug 2020 12:14

Now I use CodeBoard. It best for programming. Can define custom keys for 2 rows. But it doesn't support non-english. btw, it can switch to Gboard easy.

Post Reply