Gboard is slowing down

Post your questions and help other users.

Moderator: Martin

Horschte
Posts: 49
Joined: 03 Nov 2014 18:00

Gboard is slowing down

Post by Horschte » 14 Sep 2018 08:08

Hi guys,

I noticed that my Gboard keyboard is constantly slowing down when I type in the script action. At the beginning it is fast as usual. But after typing for a while it gets slower and slower. It takes over about a second to type one character. I have to stop Gboard to reset it. Then it is fast again but gets slower again.
Once the keyboard is slow, it is slow in other apps, too. So I assume that Automagic somehow fills up the memory of Gboard.
I had this issue before using an old Xiaomi Redmi 3 Pro. So I thought it's because of the slow phone. But I'm using an Essential Phone now and this issue occurs as well.

Is anybody else using Gboard with Automagic and can confirm the issue? Maybe it's just a setting in Gboard...

Thank you.

User avatar
digitalstone
Posts: 338
Joined: 21 Oct 2017 12:36
Location: The Netherlands

Re: Gboard is slowing down

Post by digitalstone » 14 Sep 2018 10:38

What?? I have exactly the same issue!
I searched everywhere (except here) because i didn't think it was an AutoMagic issue.


...
Looking back however, i notice that it indeed happened while i was backspacing a piece of script.

From the time as Gboard starts slowing down, it slows down more as you type more. As in: The more text you've typed within a certain textbox, the longer you have to wait until Gboard reacts, functionally as well as visually. Causing an exponential increase of annoyance and eventually making the whole system hang (if continueing long enough).

And indeed, it ripples through other apps as well.
Phone: LG Nexus 5X (rooted vanilla Android 7.1.2)

colabi
Posts: 132
Joined: 06 Jan 2013 22:33

Re: Gboard is slowing down

Post by colabi » 15 Sep 2018 21:12

Same here
Automatic 1.36 Dev
Android 8.1
Nexus 5X

User avatar
digitalstone
Posts: 338
Joined: 21 Oct 2017 12:36
Location: The Netherlands

Re: Gboard is slowing down

Post by digitalstone » 15 Sep 2018 21:58

@Horschte, do you also happen to have a Nexus 5X?
Phone: LG Nexus 5X (rooted vanilla Android 7.1.2)

Horschte
Posts: 49
Joined: 03 Nov 2014 18:00

Re: Gboard is slowing down

Post by Horschte » 15 Sep 2018 22:29

No, I'm using an Essential Phone with Android 9. Before that I had the issue with a Xiaomi Redmi 3 Pro with Android 5.1.

Today I tested a different keyboard. There where no problems at all using Automagic. So it's Gboard specific.

And indeed, the slowing down seems to begin when using backspace.

User avatar
digitalstone
Posts: 338
Joined: 21 Oct 2017 12:36
Location: The Netherlands

Re: Gboard is slowing down

Post by digitalstone » 16 Sep 2018 14:08

Oh right, yes then it's indeed Gboard all by itself.
I wonder how this could be caused though since it only happens while in Automagic.
(btw, for as things stand for now, i think it is best not to mention this bug to google in relation to Automagic??).
The Automagic keyboard is not activated on my phone, so i guess it does not have something to do with that (although i admit to not fully know what that does).
Phone: LG Nexus 5X (rooted vanilla Android 7.1.2)

User avatar
Desmanto
Posts: 2396
Joined: 21 Jul 2017 17:50

Re: Gboard is slowing down

Post by Desmanto » 16 Sep 2018 15:08

I never use Gboard for so long, so don't know about this problem. It doesn't happen with smartkeyboard.
Do all of you use Automagic accessibility when this slow down happen? Or do you have any missing permission not yet granted? I granted all the permission for Automagic.

Automagic keyboard is used in Control UI to simulate keyboard pressing. It is very unique way to type actually, you do some cool magic using it.
Index of Automagic useful thread List of my other useful posts (and others')
Xiaomi Redmi Note 5 (whyred), AOSP Extended v6.7 build 20200117 Official, Android Pie 9.0, Rooted.

User avatar
digitalstone
Posts: 338
Joined: 21 Oct 2017 12:36
Location: The Netherlands

Re: Gboard is slowing down

Post by digitalstone » 16 Sep 2018 16:11

Within Settings ---> App Info ---> Automagic Premium ---> Permissions: Everything but "Calendar", "SMS" and "access mail information"

Gboard permissions however... i found out that it is set to have NO permission at all.
I intent to leave it like that.
Phone: LG Nexus 5X (rooted vanilla Android 7.1.2)

Horschte
Posts: 49
Joined: 03 Nov 2014 18:00

Re: Gboard is slowing down

Post by Horschte » 13 Oct 2018 13:44

It seems like one of the last updates of Gboard fixed the lagging problem. I don't notice it anymore.

User avatar
digitalstone
Posts: 338
Joined: 21 Oct 2017 12:36
Location: The Netherlands

Re: Gboard is slowing down

Post by digitalstone » 13 Oct 2018 16:06

I also noticed the Gboard update but i'm almost scared to try it :|
Seems one should take a stance i guess.

But seriously, do you even see improvement when backspacing a piece of script for example?
Precisely that action alone has been the absolute Gboard smasher as of late.
Phone: LG Nexus 5X (rooted vanilla Android 7.1.2)

Post Reply