Wifi connection problem after Oreo 8.1 update

Post your questions and help other users.

Moderator: Martin

Post Reply
granaux
Posts: 4
Joined: 11 Dec 2017 04:57

Wifi connection problem after Oreo 8.1 update

Post by granaux » 12 Dec 2017 08:36

Hi, i have a flow that does certain things after connected to all wifis, but acts in different way after connected to my own home wifi (trigger wifi connected all, condition wifi connected- my wifi- true- do this, false- do that). Until now it worked perfectly, but unfortunately after december oreo update to 8.1 the flow doesnt recognize ssid of my home wifi anymore. I tried also with expression using my home router bssid, with no success. After I enter my house the flow executes, but condition wifi connected my home wifi shows value false anf the flows ends as I was connected to some other wifi, not my own. Whats more interesting if I execute flow manually with device unlocked, everything acts as it should, home wifi is recognized. Any ideas? Oreo 8.1 bug?
I tried to reset wifi settings, reboot device, no success. Stock 8.1 oreo, Nexus 6p, rooted

User avatar
Martin
Posts: 4430
Joined: 09 Nov 2012 14:23

Re: Wifi connection problem after Oreo 8.1 update

Post by Martin » 12 Dec 2017 19:44

Hi,

The condition seems to work for me on a Pixel 2 with Android 8.1. Could you please enable Debug Log and Write log to file in the settings of Automagic, wait until the flow executes again and then send the log to me?
Maybe Android 8.1 does not update the WiFi information in a timely manner. Please try to add an action Pause: 5s directly after the trigger to see if this helps.

Regards,
Martin

granaux
Posts: 4
Joined: 11 Dec 2017 04:57

Re: Wifi connection problem after Oreo 8.1 update

Post by granaux » 13 Dec 2017 04:23

Thanks a lot. I will try it

gollyzila
Posts: 18
Joined: 15 Nov 2014 21:57

Re: Wifi connection problem after Oreo 8.1 update

Post by gollyzila » 14 Dec 2017 16:23

Martin, I'm also experiencing this where WiFi doesn't trigger my flow unless I have Automagic opened in the foreground. I emailed you my logs.

User avatar
Martin
Posts: 4430
Joined: 09 Nov 2012 14:23

Re: Wifi connection problem after Oreo 8.1 update

Post by Martin » 15 Dec 2017 21:24

I heard that Google improved security and does not let apps know the SSID anymore when the location mode in the system settings is turned off.
Could you please check if you have location mode set to battery saving or high accuracy?

Regards,
Martin

granaux
Posts: 4
Joined: 11 Dec 2017 04:57

Re: Wifi connection problem after Oreo 8.1 update

Post by granaux » 16 Dec 2017 05:45

Thank You Martin now it works as it should. I used to have gps off and it was only turned on when I was using my navigation flows. I tried my home flow with gps on amd everything is OK. Thanks again for support

Post Reply