Excessive data usage overnight

Post your questions and help other users.

Moderator: Martin

Post Reply
eireox
Posts: 3
Joined: 19 Jul 2017 10:33

Excessive data usage overnight

Post by eireox » 19 Jul 2017 19:19

Hi,

I'm currently evaluating Automagic and last night I played a bit creating and deleting some flows. When I woke up I was surprised to see that battery was halved and Automagic has used 30 mb foreground and 215 mb background mobile data over the course of 3-4 hours (slow connection).

This was unexpected because there was only one active flow and it is completely local, it has nothing even remotely resembling creating a connection.

I checked the logs and there doesn't seem to be anything suspicious. There is one detail I remember that may be related: I tried to add a location condition to a flow, I had open the map view to select my location but the map didn't load (due to bad connection maybe?) I tried zooming in and out, closing and opening the map view few times to no avail. Then I gave up and didn't use it, and I ended up disabling the flow because it was not complete anyway. Maybe the map view somehow got stuck and continued downloading data in the background? If this is not the reason then I have no idea what may be.

User avatar
Scotty
Posts: 78
Joined: 26 Aug 2016 20:29
Location: Southern California

Re: Excessive data usage overnight

Post by Scotty » 20 Jul 2017 15:21

I can't advise you on your specific issue but to reassure you (since you are evaluating Automagic) I will say that I don't find it to be a battery drain. I have an older phone (Nexus 6, I love it), rooted, running 7.1.1. I try hard to minimize battery usage, and I frequently check it, using BetterBatteryStats (BBS).

On a regular workday (during which I don't actively use my phone much - some texting, a few calls, no browsing) Automagic is running constantly. BBS shows that the battery is discharging at around 1% per hour (and the phone state is usually >90% deep sleep). And that's with at least a dozen Automagic widgets on my various home screens, and probably 50 or so flows that are constantly enabled. When I use BBS to look at the processes that have used up the (small amount) of battery charge, sure, Automagic is near the top, but that's not surprising, given how many flows & widgets are always active. The things that burn through my battery are browsing and heavy file exchange. Automagic has never given me any concern at all.

Hope this helps - sorry not to be able to directly address your problem.

User avatar
Martin
Posts: 4437
Joined: 09 Nov 2012 14:23

Re: Excessive data usage overnight

Post by Martin » 21 Jul 2017 19:19

Hi,

Automagic on it's own rarely uses an internet connection but the map view will certainly transmit data. No one really knows how much and when it transmits data since it's Googles map implementation and it's not documented well.

Some other things in Automagic that will access the internet (not exhaustive):
-all network related actions (like SSH, Mail, FTP, HTTP Request etc.)
-accessing the help pages (when the offline help is not downloaded)
-converting coordinates to addresses
-speech output when Network synthesis is used
-downloading images from http and https urls in different actions that can download/show images

You could also restrict background data use of Automagic in the system settings if you don't need network related actions.
I also recommend to check the log of Automagic to see if there's a flow running unexpectedly that could transfer data.

Regards,
Martin

eireox
Posts: 3
Joined: 19 Jul 2017 10:33

Re: Excessive data usage overnight

Post by eireox » 21 Jul 2017 23:16

Scotty wrote:
Thanks Scotty, it is comforting to hear this is not a general problem but a one-off issue.
Martin wrote:
Thank you very much Martin for your interest.

I'll consider using the restrict background data option for Automagic had I decide to use it long term.


Going over your list I've never used any of these actually (even when messing around)

At that night I've experimented a little bit with different actions so I've cleared the logs few times. I don't think I cleared them after using the map view, but then I'm not sure.
Now the logs are rotated so I can't check them again, but I looked at them after this event happened and I haven't seen anything extraordinary.

There was either no active flows or there was only one. And that one flow was an older flow I've created few days before and it was a completely unrelated flow so it can't be the guilty one. On top of that I'm running the trial version so I can't have a lot of active flows to begin with.

All these makes the map view looks more suspicious now.

Here is what I did it that night, in more detail:
1. I selected the "location" condition and then the "pick location" button
2. Map view opened in "Tour Eiffel"
3. I clicked the "current location" from menu bar but it didn't work because location was turned off
4. I decided to pick my location manually so I zoomed out by pinching and clicking the "-" button several times
5. Map didn't load ( square grid view appeared), so I dragged it around a lot, also changed the radius slider left and right
6. It didn't help so I pressed "back" button (or maybe cancel button? I'm not sure) to go back
7. Then few minutes later I repeated same steps one more time to no avail.
8. I gave up, go back and deleted the condition.

I've never used the Maps API so I have no idea how it is used and how it works, but since I closed the map view and deleted the condition afterwards, I think there may be some leakage issue. Maybe some objects were not destroyed properly when the map is closed and continued to download data in background?
Attachments
t1.png
t1.png (665.87 KiB) Viewed 3388 times

Post Reply