Variables not set for Bluetooth Connected condition

Post your questions and help other users.

Moderator: Martin

Post Reply
micatlkw
Posts: 8
Joined: 04 Aug 2016 02:34

Variables not set for Bluetooth Connected condition

Post by micatlkw » 07 Oct 2016 05:00

variables connected_devices_addresses and connected_devices_names are not set

User avatar
MURTUMA
Posts: 697
Joined: 05 Mar 2013 22:43

Re: Variables not set for Bluetooth Connected condition

Post by MURTUMA » 07 Oct 2016 10:54

Please, be more specific. This needs a use case to determine where the problem lies.

When the flow runs through the condition, are there any bluetooth devices connected?

micatlkw
Posts: 8
Joined: 04 Aug 2016 02:34

Re: Variables not set for Bluetooth Connected condition

Post by micatlkw » 07 Oct 2016 19:10

I am sorry that if I wasn't clear. When the condition runs, there are device connected. I expected the variables are assigned with the condition returns true. However, they are empty.

User avatar
Martin
Posts: 4463
Joined: 09 Nov 2012 14:23

Re: Variables not set for Bluetooth Connected condition

Post by Martin » 07 Oct 2016 19:40

The variables are propagated on my device when a BT device is connected.
Could you please execute a flow like this and check if the variables are really not available?
-...
-condition Bluetooth Device Connected
--> true: -condition Debug Dialog

I would be glad if you could send me a log if the variables are still empty but the condition remains true (turn on debug logging in the preferences of Automagic then execute above flow, go to the flow list and use menu->Manage->Log, menu->Send Log).

Thanks & Regards,
Martin

User avatar
Martin
Posts: 4463
Joined: 09 Nov 2012 14:23

Re: Variables not set for Bluetooth Connected condition

Post by Martin » 07 Oct 2016 20:11

Probably found the problem. The variables are not set when only a specific bluetooth profile is checked. This should be fixed in the next update.
Thanks for reporting!

Regards,
Martin

micatlkw
Posts: 8
Joined: 04 Aug 2016 02:34

Re: Variables not set for Bluetooth Connected condition

Post by micatlkw » 08 Oct 2016 03:09

More information, in my condition, I set it to check if any bt device (Not specific one) connected to the headset profile. Not sure this match your finding

User avatar
Martin
Posts: 4463
Joined: 09 Nov 2012 14:23

Re: Variables not set for Bluetooth Connected condition

Post by Martin » 10 Oct 2016 18:36

Yes, the problem was caused by the setting to check the headset profile only.

Regards,
Martin

micatlkw
Posts: 8
Joined: 04 Aug 2016 02:34

Re: Variables not set for Bluetooth Connected condition

Post by micatlkw » 11 Oct 2016 04:12

Thanks!

Post Reply