Inbound calls issue

Post your questions and help other users.

Moderator: Martin

Post Reply
Do3oP
Posts: 6
Joined: 15 Apr 2013 16:04

Inbound calls issue

Post by Do3oP » 15 Apr 2013 16:24

Hi all, Yesterday I installed Auto Magic and tries to create a very simple rule that allows me to accept incoming calls automatically.
So I created a rule that looks as follows:
Image
Trigger: For all Inbound calls, if call status ringing
Conditions: wait 3s
Action: call accept
No matter what I tried it just will not accepted the calls.

Can someone please help me. What I´m doing wrong or maybe someone had the same problem that the incoming calls are not automatically accepted?

p.s I have Samsung S3 LTE with Root and custom rom.
Last edited by Do3oP on 16 Apr 2013 10:11, edited 2 times in total.

inReinbek
Posts: 95
Joined: 02 Feb 2013 22:04

Re: Inbound calls issue

Post by inReinbek » 16 Apr 2013 08:18

Hi Do3oP,

maybe your custom-rom do not support the "auto-answer"-option ?!

Regards

Do3oP
Posts: 6
Joined: 15 Apr 2013 16:04

Re: Inbound calls issue

Post by Do3oP » 16 Apr 2013 10:11

inReinbek wrote:maybe your custom-rom do not support the "auto-answer"-option ?!Regards
How can i find it out?

inReinbek
Posts: 95
Joined: 02 Feb 2013 22:04

Re: Inbound calls issue

Post by inReinbek » 16 Apr 2013 13:22

Maybe changing your ROM into an offical from Samsung tested one ?

User avatar
Martin
Posts: 4345
Joined: 09 Nov 2012 14:23

Re: Inbound calls issue

Post by Martin » 17 Apr 2013 14:18

This action works for me on a rooted S3 with stock ROM (4.1.2).

Please enable debug log, let the flow execute and see if you can find a line like the following:
17.04.2013 16:00:00 [Flow X] Action 'Answer Ringing Call' returned processed=true

Ensure that you have no filter set in the log (press the pencil-button and remove the filter or open the unfiltered log from the flowlist menu->Manage->Log).

Sometimes it helps to keep 'Root functions' enabled in the preferences, then uninstall Automagic and reinstall Automagic.

Do3oP
Posts: 6
Joined: 15 Apr 2013 16:04

Re: Inbound calls issue

Post by Do3oP » 17 Apr 2013 16:17

Image

Befor i take this picture I have keep 'Root functions' enabled, then uninstall and reinstall Automagic.

Post Reply