Search found 147 matches

by vertigo
23 Sep 2020 19:35
Forum: User Help / Bug Reports
Topic: Triggering other flow with intent (to send vars)
Replies: 0
Views: 5385

Triggering other flow with intent (to send vars)

I'm trying to have various stages in one flow trigger another flow while telling that flow what stage it's on. This could be done by setting a glovar then executing the other flow and having that flow look at the glovar then remove it (to keep down clutter), and that would be a simple enough solutio...
by vertigo
23 Sep 2020 19:30
Forum: User Help / Bug Reports
Topic: The End of Automagic
Replies: 53
Views: 49620

Re: The End of Automagic

I unfortunately had a feeling this was coming due to the lack of updates for a while now. This definitely sucks both due to the loss of a great program and the fact I've spent a fair amount of time playing around in it, becoming more familiar with it and coming up with lots of neat things to do, inc...
by vertigo
20 Jul 2020 15:59
Forum: User Help / Bug Reports
Topic: Flows occasionally get stuck executing debug dialog; AM inccorectly states missing permissions
Replies: 9
Views: 7170

Re: Flows occasionally get stuck executing debug dialog; AM inccorectly states missing permissions

I do think it should be able to deal with the problem, though, when stopping a flow while stuck on something. For example, if a flow is stopped, AM should be able to see that a debug condition is stuck active and close the dialog, which may be hidden as you describe, so the flow actually stops as it...
by vertigo
08 Jul 2020 18:08
Forum: Feature Requests
Topic: Hardware Key Event Boolean AND
Replies: 2
Views: 4072

Re: Hardware Key Event Boolean AND

Thanks! Hopefully you're right and it is added in the new version, which would greatly simplify things, though I suppose it's something that'll only be used once. Anyway, your setup got me on the right track, and I just made a minor modification to make it work better. I added a 2x in 500ms executio...
by vertigo
06 Jul 2020 21:13
Forum: User Help / Bug Reports
Topic: Volume bug with Sound action
Replies: 9
Views: 6661

Re: Volume bug with Sound action

Ok, so I found the issue with the notification stream and why it works sometimes and not others. When the proximity sensor is covered, that's when the sound is quiet. If I run the first flow, the one that just plays a notification sound, while covering the proximity sensor (which is required for the...
by vertigo
06 Jul 2020 20:57
Forum: User Help / Bug Reports
Topic: Volume bug with Sound action
Replies: 9
Views: 6661

Re: Volume bug with Sound action

The results are kinda all over the place: Music, notification, and voice call streams work properly, though the notification stream is what I use in the other flow to play notification sounds, where I first discovered the problem. So in this flow it works, in that flow it doesn't. And in this flow, ...
by vertigo
06 Jul 2020 20:10
Forum: Feature Requests
Topic: Add local only option to execution count condition
Replies: 1
Views: 3085

Add local only option to execution count condition

As described here , this condition works globally, which is confusing since it doesn't specify that on the help page. One fix, which would be easier, would be to simply edit that page to say that, but another, better fix would be to add a way to select between making it global or local, to allow use...
by vertigo
06 Jul 2020 20:07
Forum: User Help / Bug Reports
Topic: Execution Count condition issues
Replies: 5
Views: 5169

Re: Execution Count condition issues

I executed it manually (didn't even know that was possible) and it did increment, so not sure why it doesn't if I run the flow then check it. Definitely seems to be a bug. Also, as mentioned, the bigger issue here is that the help page for the condition simply isn't clear at all about the fact it's ...
by vertigo
06 Jul 2020 19:30
Forum: User Help / Bug Reports
Topic: Flows occasionally get stuck executing debug dialog; AM inccorectly states missing permissions
Replies: 9
Views: 7170

Re: Flows occasionally get stuck executing debug dialog; AM inccorectly states missing permissions

I'm pretty sure it's not battery optimization, which doesn't seem too aggressive on my phone and, as I said, it happens even when AM is the most recent app and only under a fairly specific circumstance (debug dialog). I'll have to try and remember to execute it again to see if it shows me the dialog...